Developer & Text Tools

239 tools · page 4 of 4

  • Табдилдиҳандаи IDN Punycode Номи домени байналмилалишударо байни шакли Unicode ва ASCII Punycode (xn--) дар ҳар ду самт табдил диҳед.
  • Тафтишгари Personnummer-и шведӣ Personnummer-и шведиро бо ҳисоб кардани суммаи назоратии Luhn барои нӯҳ рақами аввал (YYMMDD-NNN) ва муқоиса бо рақами назоратии охирин тафтиш мекунад. Ҷудокунандаҳо худкор тоза мешаванд.
  • Ҳисобкунаки сифрҳои пешбар Битҳои сифри пешбари (CLZ) бутуни беаломатро барои бари битии интихобшуда мешуморад.
  • Ҷустуҷӯи имзои файл (рақами ҷодугарӣ) Формати файлро аз байтҳои пешбари рақами ҷодугарии он, бо мутобиқ кардани имзои hex бо навъҳои маъмули тасвир, бойгонӣ, ҳуҷҷат ва иҷрошаванда муайян мекунад.
  • Декодери IEEE 754 дақиқии ягона Аз 8 рақами шонздаҳӣ адади бо нуқтаи шинокори дақиқии ягонаи 32-битаи IEEE 754-ро декод мекунад ва қимматро ҳамроҳ бо майдонҳои аломат, дараҷа ва мантисса нишон медиҳад.
  • Табдилдиҳандаи Camel Case Ҳар гуна ибораро бо тақсим кардан аз рӯи фосилаҳо, зерхатҳо, тиреҳо ва аломатҳои китобат ба camelCase ва PascalCase табдил диҳед.
  • Табдилдиҳандаи номи ранг ба HEX Номи стандартии ранги CSS-ро ба коди HEX ва қимати RGB-и он табдил медиҳад.
  • Ҳисобкунаки фишурдани IPv6 Суроғаи пурра кушодашудаи IPv6-ро бо нест кардани сифрҳои пешбар ва муттаҳид кардани дарозтарин пайдарпайии гурӯҳҳои сифр ба :: фишурда мекунад.
  • Ҳисобкунаки ҳаҷми Base64 Ҳаҷми рамзгузошташуда ва иловагиро ҳангоми рамзгузории додаҳо ҳамчун Base64 ҳисоб кунед.
  • Ҳисобкунаки wildcard mask Ниқоби зершабакаро дар навишти даҳии нуқтавӣ ба wildcard mask-и баръакси он, ки дар Cisco ACL ва OSPF истифода мешавад, табдил диҳед. Ҳар октет ба 255 минус октети ниқоб баробар мешавад.
  • Ҳисобкунаки вазни Ҳемминг Шумораи битҳои танзимшуда (якҳо)-ро дар адади бутуни ғайриманфӣ, ки бо системаи даҳӣ, шонздаҳӣ ё дуӣ ворид шудааст, ҳисоб мекунад. Инчунин ҳисоби аҳолӣ (popcount) номида мешавад.
  • Рамзгузори Base85 RFC 1924 Адади бутуни ғайриманфиро бо тақсими такрорӣ ба 85 ва истифодаи алифбои RFC 1924 ба сатри Base85 рамзгузорӣ мекунад.
  • Табдилдиҳандаи CSV ба ҷадвали Markdown Маълумоти CSV-ро, ки бо вергул ё нуқтавергул ҷудо шудаанд, ба ҷадвали форматшудаи Markdown бо мувофиқати интихобшавандаи сутунҳо табдил медиҳад.
  • Ҳисобкунаки рақами санҷишии GTIN-14 Рақами санҷишии GS1 mod-10-ро барои GTIN-14 аз 13 рақами аввалаш ҳисоб карда, коди пурраи 14-рақамаро бармегардонад.
  • Абзори тоза кардани тегҳои HTML Ҳамаи тегҳои HTML-ро тоза карда, объектҳоро кодкушоӣ мекунад ва матни оддии тоза ва шумораи аломатҳоро бармегардонад.
  • Табдилгари JSON ба XML Объекти оддии JSON-ро ба XML-и зебо форматшуда табдил медиҳад: ҳар калидро ба унсур табдил дода, объектҳои фарзандро дарунгузорӣ мекунад ва ҳамаро бо тэги реша мепечонад.
  • Ҳисобкунаки umask Қимати umask-ро ба иҷозатҳои пешфарзе, ки он барои файлҳои нав (666 & ~umask) ва директорияҳо (777 & ~umask) эҷод мекунад, табдил диҳед.
  • Маълумотномаи майдонҳои Whois Маънои майдонеро дар сабти WHOIS-и домен, ба монанди санаи эҷод, бақайдгиранда, сервери ном ё ҳолати домен ёбед.
  • Рамзи ивазкунии гомофонӣ Матнро бо нақшаи соддакардашудаи таълимии ивазкунии гомофонӣ рамзгузорӣ мекунад, ки дар он як ҳарф вобаста ба мавқеи худ ба рамзҳои гуногуни дурақама нигошта мешавад.
  • Табдилдиҳандаи NDJSON ба массиви JSON JSON-и бо сатрҳои нав ҷудошударо (як объект дар як сатр) таҳлил мекунад ва сатрҳоро ба як массиви JSON-и зебоформатшуда якҷоя мекунад.
  • Ҳисобкунаки ҳосили иқтидор-таъхир Ҳосили иқтидор-таъхирро (тирезаи оптималии TCP) аз рӯи иқтидори пайванд ва вақти рафту баргашт ҳисоб кунед.
  • Рамзгузори шифри VIC (тахтаи шашкаи густаришёбанда) Матнро бо тахтаи шашкаи густаришёбанда рамз мекунад — ин ядрои ивазкунии шифри VIC аст. Соддашуда: ҷамъи занҷирӣ ва ҷойивазкуниро дар бар намегирад, бинобар ин шифри пурраи VIC нест.
  • Табдилгари CONSTANT_CASE Ҳар гуна матн ё муайянкунандаро бо тақсим кардан аз рӯи фосилаҳо, дефисҳо ва ҳудуди camelCase ва баъд пайваст кардани калимаҳои ҳарфи калон бо хатчаи зерин ба CONSTANT_CASE табдил диҳед.
  • Табдилгари Punycode Як барчаспи домени Unicode-ро бо истифода аз алгоритми bootstring-и RFC 3492 ба шакли Punycode (xn--)-и он рамзгузорӣ мекунад.
  • Ҳисобкунаки калиди Диффи-Ҳелман Сирри муштарак ва калидҳои оммавии Диффи-Ҳелманро аз адади содда, генератор ва ду калиди шахсӣ ҳисоб мекунад.
  • Абзори Escape-и Regex Метааломатҳои ифодаи муқаррарӣ (regex)-ро дар матни шумо бо илова кардани хатчаи каҷи баръакс пеш аз ҳар яке escape мекунад, то сатр калима ба калима мувофиқат кунад.
  • Абзори ROT13/ROT5 Дар як табдил ROT13-ро ба ҳарфҳо ва ROT5-ро ба рақамҳо татбиқ мекунад — рамзи маъмул барои муаммоҳо ва пинҳонкунӣ. Натиҷаро бо як клик нусхабардорӣ кунед.
  • Абзори вариантҳои квадрати Полибиус (тахтаи шоҳмот) Матнро бо квадрати Полибиуси бо калимаи калидӣ омехташуда (варианти тахтаи шоҳмот) рамзгузорӣ ё рамзкушоӣ мекунад ва ҳарфҳоро ба ҷуфтҳои рақамҳои сатр/сутун нақша мекунад.
  • Абзори тоза кардани аломатҳои диакритикӣ Аксентҳо ва аломатҳои диакритикиро аз матн тоза кунед ва ҳарфҳои монанди é, ü ва ñ-ро ба ASCII-и оддӣ табдил диҳед.
  • Баҳодиҳандаи шумораи саҳифаҳо Шумораи саҳифаҳоро аз шумораи калимаҳо баҳо диҳед. Баҳодиҳандаи шумораи саҳифаҳо ба шумо натиҷаро фавран аз вуруди оддӣ медиҳад.
  • Декодери yEnc Сатри бо yEnc рамзгузоришударо бозгашта ба матн (ё hex барои маълумоти дуӣ) декод мекунад. Соддакардашуда: =гурезро дастгирӣ мекунад, аммо сарлавҳаҳои =ybegin/=ypart/=yend-ро не.
  • Калкулятори иҷрои навбатии crontab Ифодаи стандартии crontab-и 5-майдонаро таҷзия карда, вақтҳои иҷрои банақшагирифташудаи навбатиро пас аз вақти асосӣ (UTC) номбар мекунад.
  • Мутобиқсози рангҳои бехатари веб Ҳар канали RGB-и ранги hex-ро ба наздиктарин қимати бехатари веб (0, 51, 102, 153, 204, 255) ҷамъбандӣ мекунад ва коди hex-и мувофиқро бармегардонад.
  • Рамзгузор/рамзкушои шифри Phillips Матнро бо шифри Phillips рамзгузорӣ ё рамзкушоӣ кунед; ин шифр ҳашт квадрати калиддори 5×5 Полибийро истифода мебарад, ки дар ҳар блоки панҷҳарфӣ навбат мегиранд.
  • Рамзгузори Bech32 Префикси хонданашаванда ва байтҳои hex-и барномаи witness-ро ба сатри bech32-и дорои ҷамъи санҷишӣ (BIP173) рамзгузорӣ кунед.
  • Табдилгари калимаҳо ба байтҳо Байни калимаҳои мошинӣ ва байтҳо барои андозаи калимаи интихобшавандаи 16, 32 ё 64 бит дар ҳарду самт табдил медиҳад.
  • Табдилгари массиви JSON ба NDJSON Массиви JSON-ро ба JSON-и бо сатрҳои нав ҷудошуда (NDJSON) табдил диҳед; барои стриминг, сабтҳо ва қубурҳои додаҳо дар ҳар сатр як қимати фишурдаи JSON мебарорад.
  • Табдилдиҳандаи Title Case Ҳар матнро ба title case-и дурусти англисӣ табдил диҳед; калимаҳои кӯтоҳ ба мисли 'of' ва 'the' бо ҳарфи хурд мемонанд.
  • Табдилдиҳандаи аломатҳои ҳисобӣ Адади бутунро ба аломатҳои ҳисобӣ табдил медиҳад ва ҳар панҷро бо аломати гурӯҳии хатзада гурӯҳбандӣ мекунад.
  • Табдилдиҳандаи ивазкунии Dvorak Матнро тавре табдил медиҳад, ки гӯё ҳамон тугмаҳои физикӣ дар тарҳбандии дигари клавиатура пахш шуда бошанд ва ҳар ҳарфро байни мавқеъҳои тугмаҳои QWERTY ва Dvorak харита мекунад.
  • Табдилдиҳандаи фосилаҳо ба табҳо Ҳар як қатори фосилаҳои аввалро бо паҳноие, ки шумо муайян мекунед, ба аломатҳои таб табдил медиҳад, сатр ба сатр.
  • Тавлидгари ибораи парол Аз тухм ба таври муайян ибораи паролии калимавии дар ёд монданро месозад, бинобар ин як тухм ҳамеша як ибораро медиҳад. Энтропияи тахминиро гузориш медиҳад.
  • Тавлидкунандаи матни тамасхуромез Матни шуморо ба услуби мемии SpongeBob бо навбати ҳарфҳои калон ва хурд табдил медиҳад.
  • Тарҷумони Pig Latin Матни англисиро ба Pig Latin тарҷума кунед, бо кӯчонидани ҳамсадоҳои аввал ва иловаи анҷоми дуруст.
  • Тарҷумони клавиатураи телефон Ҳарфҳоро ба рақамҳои клавиатураи телефон (ABC=2 ... WXYZ=9) табдил медиҳад, то шумо рақами телефони ҳарфиро гирад тавонед.
  • Тарҷумони рамзи тақ-тақ (tap code) Матнро ба рамзи тақ-тақ ва баръакс табдил медиҳад — рамзи квадрати Полибиуси 5x5, ки маҳбусон истифода мебурданд.
  • Тасдиқкунандаи версияи семантикӣ Тафтиш кунед, ки оё сатр версияи дурусти Semantic Versioning 2.0.0 аст ва қисмҳои major, minor, patch, pre-release ва build-и онро ҷудо кунед.
  • Тафтишгари рақами ААИ Формати рақами ААИ-и ИА-ро аз рӯи префикси кишвар ва дарозии зарурӣ тафтиш мекунад (DE, FR, IT, ES, NL), бо қайд дар бораи рақами назоратии олмонӣ. Танҳо тафтиши формат — на дархости феҳристи зинда.
  • Ҳисобкунаки басомади калимаҳо Ҳисоб кунед, ки ҳар калима дар матн чанд бор меояд, аз бештарин то камтарин мураттаб карда шудааст.
  • Ҳисобкунаки бити AND OR XOR Амалҳои бити AND, OR ва XOR-и ду адади бутуни номанфиро ҳисоб кунед; XOR дар шакли бинарӣ низ нишон дода мешавад.
  • Ҳисобкунаки қувваи парол Энтропияи пароли шумо аз рӯи маҷмӯи аломатҳо ва тахмини вақт барои шикастани он бо қувваи бераҳмона.
  • Ҳисобкунаки масофаи Левенштейн Масофаи таҳририи Левенштейнро байни ду сатр ва фоизи монандии онҳоро ҳисоб кунед.
  • Ҳисобкунаки ранги мукаммалкунанда Ранги мукаммалкунандаи арзиши hex-ро бо чарх задани тобиш ба 180° дар HSL меёбад ва инчунин алтернативаи баръакси RGB-ро медиҳад.
  • Ҳисобкунаки рангҳои триадӣ Барои ҳар ранги hex ду ранги шарики триадиро (тобиш ±120° дар чархи рангҳо) ёбед ва палитраи пурраи серангаро гиред.
  • Ҳисобкунаки садонокҳо ва ҳамсадоҳо Садонокҳо ва ҳамсадоҳоро дар матн ҳисоб кунед. Ҳисобкунаки садонокҳо ва ҳамсадоҳо ба шумо натиҷаро фавран аз вуруди оддӣ медиҳад.
  • Ҳисобкунаки суммаи назоратии интернет Суммаи назоратии 16-битаи интернети (RFC 1071) маълумоти шонздаҳиро ҳисоб кунед — суммаи иловагии як, ки дар сарлавҳаҳои IP, TCP ва UDP истифода мешавад. Суммаҳои назоратии сарлавҳаро тафтиш ё тавлид кунед.
  • Ҳисобкунаки суммаи санҷишии BSD Суммаи санҷишии классикии BSD sum-16-и матни воридшударо (алгоритми 16-битаи давр-зан-ва-ҷамъ, ки фармони sum-и Unix истифода мебарад) дар системаи даҳӣ ва шонздаҳӣ ҳисоб мекунад.
  • Ҳисобкунаки табдили бод ба суръати бит Суръати битро аз суръати бод ва битҳо ба ҳар рамз ҳисоб кунед. Ҳисобкунаки табдили бод ба суръати бит ба шумо натиҷаро аз вуруди оддӣ фавран медиҳад.
  • Шарҳдиҳандаи ифодаи cron Ифодаи cron-и 5-майдонаро (дақиқа соат рӯзи моҳ моҳ рӯзи ҳафта) таҳлил мекунад ва бо забони содда тавсиф мекунад, ки кай иҷро мешавад.