Developer & Text Tools
239 tools · page 4 of 4
- IDN Punycode மாற்றி சர்வதேசமயமாக்கப்பட்ட டொமைன் பெயரை Unicode மற்றும் ASCII Punycode (xn--) வடிவத்திற்கு இடையே இரு திசைகளிலும் மாற்றவும்.
- கோப்பு கையொப்பம் (மேஜிக் எண்) தேடல் hex கையொப்பத்தை பொதுவான படிமம், காப்பகம், ஆவணம் மற்றும் இயக்கக்கூடிய வகைகளுடன் பொருத்தி, ஒரு கோப்பின் முன்னணி மேஜிக்-எண் பைட்டுகளிலிருந்து அதன் வடிவமைப்பை அடையாளம் காண்கிறது.
- முன்னணி பூஜ்ஜிய எண்ணி தேர்ந்தெடுக்கப்பட்ட பிட் அகலத்திற்கு கையொப்பமற்ற முழு எண்ணின் முன்னணி பூஜ்ஜிய பிட்களை (CLZ) எண்ணுகிறது.
- ஸ்வீடிஷ் Personnummer சரிபார்ப்பான் முதல் ஒன்பது இலக்கங்களில் (YYMMDD-NNN) Luhn செக்சம் இயக்கி, இறுதி காசோலை இலக்கத்துடன் ஒப்பிட்டு ஸ்வீடிஷ் Personnummer-ஐ சரிபார்க்கிறது. பிரிப்பான்கள் தானாக நீக்கப்படும்.
- நிற பெயரிலிருந்து HEX மாற்றி நிலையான CSS நிற பெயரை அதன் HEX குறியீடு மற்றும் RGB மதிப்பாக மாற்றுகிறது.
- Base64 அளவு கணிப்பான் தரவை Base64 ஆக குறியீடாக்கும்போது குறியீடாக்கப்பட்ட அளவு மற்றும் கூடுதல் சுமையைக் கணக்கிடுங்கள்.
- Camel Case மாற்றி இடைவெளிகள், அடிக்கோடுகள், இடைக்கோடுகள் மற்றும் நிறுத்தற்குறிகளில் பிரித்து எந்த சொற்றொடரையும் camelCase மற்றும் PascalCase ஆக மாற்றவும்.
- IEEE 754 ஒற்றை டிகோடர் 8 பதினறும எண்களிலிருந்து 32-பிட் IEEE 754 ஒற்றைத் துல்லிய மிதவை எண்ணை டிகோடு செய்து, மதிப்புடன் குறி, அடுக்கு மற்றும் மாண்டிசா புலங்களைக் காட்டுகிறது.
- IPv6 அமுக்க கால்குலேட்டர் முழுமையாக விரிவாக்கப்பட்ட IPv6 முகவரியை முன்னணி பூஜ்ஜியங்களை நீக்கி, பூஜ்ஜியக் குழுக்களின் நீளமான தொடரை :: ஆக ஒன்றிணைத்து அமுக்குகிறது.
- ஹேமிங் எடை கணிப்பான் தசம, பதினறும அல்லது இருமத்தில் உள்ளிடப்பட்ட எதிர்மறையற்ற முழு எண்ணில் அமைக்கப்பட்ட பிட்களின் (1-கள்) எண்ணிக்கையை எண்ணுகிறது. இது population count (popcount) எனவும் அழைக்கப்படுகிறது.
- wildcard mask கணிப்பான் புள்ளி-தசம குறியீட்டில் உள்ள ஒரு துணைவலை மாஸ்க்கை, Cisco ACL மற்றும் OSPF இல் பயன்படுத்தப்படும் அதன் தலைகீழ் wildcard mask ஆக மாற்றவும். ஒவ்வொரு ஆக்டெட்டும் 255 கழித்தல் மாஸ்க் ஆக்டெட் ஆகிறது.
- Base85 RFC 1924 குறியாக்கி 85 ஆல் மீண்டும் மீண்டும் வகுத்து RFC 1924 எழுத்துவரிசையைப் பயன்படுத்தி எதிர்மறையற்ற முழு எண்ணை Base85 சரமாக குறியாக்குகிறது.
- CSV இலிருந்து Markdown அட்டவணை மாற்றி காற்புள்ளி அல்லது அரைப்புள்ளியால் பிரிக்கப்பட்ட CSV தரவை, தேர்ந்தெடுக்கக்கூடிய நெடுவரிசை சீரமைப்புடன் வடிவமைக்கப்பட்ட Markdown அட்டவணையாக மாற்றுகிறது.
- GTIN-14 செக் டிஜிட் கால்குலேட்டர் முதல் 13 இலக்கங்களிலிருந்து GTIN-14 க்கான GS1 mod-10 செக் டிஜிட்டைக் கணக்கிட்டு முழுமையான 14-இலக்கக் குறியீட்டைத் தருகிறது.
- HTML டேக்குகளை நீக்கும் கருவி அனைத்து HTML டேக்குகளையும் நீக்கி எண்டிட்டிகளை டிகோடு செய்து, தூய சாதாரண உரை மற்றும் எழுத்து எண்ணிக்கையைத் தருகிறது.
- JSON to XML மாற்றி எளிய JSON பொருளை அழகாக வடிவமைக்கப்பட்ட XML ஆக மாற்றுகிறது; ஒவ்வொரு விசையையும் ஒரு கூறாக மாற்றி, துணைப் பொருள்களை உள்ளடக்கி, அனைத்தையும் ஒரு மூல குறிச்சொல்லில் சுற்றுகிறது.
- Umask கணிப்பான் ஒரு umask மதிப்பை, புதிய கோப்புகளுக்கு (666 & ~umask) மற்றும் கோப்பகங்களுக்கு (777 & ~umask) அது உருவாக்கும் இயல்பு அனுமதிகளாக மாற்றவும்.
- அலைவரிசை-தாமத பெருக்கல் கணிப்பான் இணைப்பு அலைவரிசை மற்றும் சுற்றுப்பயண நேரத்திலிருந்து அலைவரிசை-தாமத பெருக்கலை (உகந்த TCP சாளரம்) கணக்கிடுங்கள்.
- ஒலியொத்த பதிலீட்டு மறையீடு எளிமைப்படுத்தப்பட்ட கல்வி நோக்கிலான ஒலியொத்த பதிலீட்டு முறையில் உரையை மறையாக்குகிறது; இதில் ஒரே எழுத்து அதன் இடத்தைப் பொறுத்து வெவ்வேறு 2-இலக்க குறியீடுகளுக்கு வரைபடமாக்கப்படுகிறது.
- NDJSON இலிருந்து JSON அணியாக மாற்றி புதிய வரியால் பிரிக்கப்பட்ட JSON ஐ (ஒரு வரிக்கு ஒரு பொருள்) பகுப்பாய்வு செய்து, வரிகளை அழகாக வடிவமைக்கப்பட்ட ஒரே JSON அணியாக இணைக்கிறது.
- Whois புல குறிப்பு உருவாக்கப்பட்ட தேதி, பதிவாளர், பெயர் சேவையகம் அல்லது டொமைன் நிலை போன்ற ஒரு டொமைனின் WHOIS பதிவில் உள்ள ஒரு புலத்தின் அர்த்தத்தைத் தேடவும்.
- டிஃபி-ஹெல்மன் சாவி கால்குலேட்டர் ஒரு பகா எண், ஜெனரேட்டர் மற்றும் இரண்டு தனிப்பட்ட சாவிகளிலிருந்து டிஃபி-ஹெல்மன் பகிரப்பட்ட ரகசியம் மற்றும் பொது சாவிகளைக் கணக்கிடுகிறது.
- CONSTANT_CASE மாற்றி எந்த உரையையும் அல்லது அடையாளங்காட்டியையும் இடைவெளிகள், இணைப்புக்கோடுகள் மற்றும் camelCase எல்லைகளில் பிரித்து, பின்னர் பெரிய எழுத்து சொற்களை அடிக்கோட்டால் இணைத்து CONSTANT_CASE-ஆக மாற்றுங்கள்.
- Punycode மாற்றி RFC 3492 bootstring அல்காரிதத்தைப் பயன்படுத்தி ஒரு Unicode டொமைன் லேபிளை அதன் Punycode (xn--) வடிவத்திற்கு குறியாக்கம் செய்கிறது.
- VIC மறையாக்கம் (விரிந்த சதுரங்கப் பலகை) குறியாக்கி விரிந்த சதுரங்கப் பலகையைப் பயன்படுத்தி உரையைக் குறியாக்கம் செய்கிறது, இது VIC மறையாக்கத்தின் பதிலீட்டு மையம். எளிமைப்படுத்தப்பட்டது: சங்கிலி கூட்டல் மற்றும் இடமாற்றத்தைத் தவிர்க்கிறது, எனவே இது முழு VIC மறையாக்கம் அல்ல.
- இடைவெளிகளை தத்தல்களாக மாற்றி ஒவ்வொரு வரியின் தொடக்கத்திலுள்ள இடைவெளித் தொடரை நீங்கள் அமைத்த அகலத்தில் தத்தல் எழுத்துகளாக வரி வரியாக மாற்றுகிறது.
- இணைய செக்சம் கணிப்பான் ஹெக்ஸாடெசிமல் தரவின் 16-பிட் இணைய செக்சம் (RFC 1071) கணக்கிடுங்கள் — IP, TCP மற்றும் UDP தலைப்புகளில் பயன்படுத்தப்படும் ஒன்றின் நிரப்பு கூட்டுத்தொகை. தலைப்பு செக்சம்களைச் சரிபார்க்கவும் அல்லது உருவாக்கவும்.
- உச்சரிப்புக் குறிகள் நீக்கும் கருவி உரையிலிருந்து உச்சரிப்பு மற்றும் டயாக்ரிடிக் குறிகளை நீக்கி, é, ü, ñ போன்ற எழுத்துக்களை சாதாரண ASCII ஆக மாற்றுங்கள்.
- உயிரெழுத்து மற்றும் மெய்யெழுத்து எண்ணி ஒரு உரையில் உயிரெழுத்துகள் மற்றும் மெய்யெழுத்துகளை எண்ணவும். உயிரெழுத்து மற்றும் மெய்யெழுத்து எண்ணி எளிய உள்ளீட்டிலிருந்து உடனடியாக முடிவைத் தரும்.
- எண்ணிக்கைக் குறிகள் மாற்றி ஒரு முழு எண்ணை எண்ணிக்கைக் குறிகளாக மாற்றி, ஒவ்வொரு ஐந்தையும் ஒரு குறுக்குக் கோடிட்ட குழுச் சின்னத்துடன் தொகுக்கிறது.
- க்ரான் வெளிப்பாடு விளக்கி 5 புலங்கள் கொண்ட க்ரான் வெளிப்பாட்டை (நிமிடம் மணி மாதத்தின் நாள் மாதம் வாரத்தின் நாள்) பகுப்பாய்வு செய்து, அது எப்போது இயங்கும் என்பதை எளிய மொழியில் விளக்குகிறது.
- கடவுச்சொல் வலிமை கால்குலேட்டர் உங்கள் கடவுச்சொல்லின் எழுத்துத் தொகுப்பிலிருந்து அதன் என்ட்ரோபி மற்றும் அதை ப்ரூட் ஃபோர்ஸ் முறையில் உடைக்க ஆகும் நேரத்தின் மதிப்பீடு.
- கடவுச்சொற்றொடர் உருவாக்கி ஒரு விதையிலிருந்து தீர்மானகரமாக நினைவில் வைக்கக்கூடிய சொல் அடிப்படையிலான கடவுச்சொற்றொடரை உருவாக்குகிறது, எனவே அதே விதை எப்போதும் அதே சொற்றொடரைத் தரும். மதிப்பிடப்பட்ட என்ட்ரோபியை அறிவிக்கிறது.
- கேலி எழுத்து உருவாக்கி உங்கள் உரையை பெரிய மற்றும் சிறிய எழுத்துகள் மாறி மாறி வரும் SpongeBob மீம் பாணியாக மாற்றுகிறது.
- செக்கர்போர்டு பாலிபியஸ் மாறுபாடு கருவி ஒரு சாவிச்சொல்லால் கலக்கப்பட்ட பாலிபியஸ் சதுரத்துடன் (செக்கர்போர்டு மாறுபாடு) எழுத்துகளை வரிசை/நெடுவரிசை இலக்க இணைகளாக வரைபடமாக்கி உரையை மறையாக்கம் அல்லது மறைநீக்கம் செய்கிறது.
- சொல் அதிர்வெண் எண்ணி ஒரு உரையில் ஒவ்வொரு சொல்லும் எத்தனை முறை வருகிறது என்பதை எண்ணி, அதிகம் முதல் குறைவு வரை வரிசைப்படுத்துங்கள்.
- சொற்பொருள் பதிப்பு சரிபார்ப்பான் ஒரு சரம் சரியான Semantic Versioning 2.0.0 பதிப்பா என்பதைச் சரிபார்த்து, அதன் major, minor, patch, pre-release மற்றும் build பகுதிகளைப் பிரிக்கவும்.
- தட்டல் குறியீடு மொழிபெயர்ப்பாளர் (Tap Code) உரையை, கைதிகள் பயன்படுத்திய 5x5 பாலிபியஸ் தட்டல் மறையான தட்டல் குறியீட்டிற்கும் அதிலிருந்தும் மாற்றுகிறது.
- தொலைபேசி கீபேட் மொழிபெயர்ப்பாளர் எழுத்துக்களை தொலைபேசி கீபேடில் உள்ள இலக்கங்களாக (ABC=2 ... WXYZ=9) மாற்றுகிறது, இதனால் எழுத்து தொலைபேசி எண்ணை அழைக்கலாம்.
- நிரப்பு நிற கணிப்பான் HSL-இல் வண்ணத்தை 180° சுழற்றி ஒரு hex மதிப்பின் நிரப்பு நிறத்தைக் கண்டறிகிறது, மேலும் RGB-தலைகீழ் மாற்றீட்டையும் வழங்குகிறது.
- பக்க எண்ணிக்கை மதிப்பீட்டாளர் சொல் எண்ணிக்கையிலிருந்து பக்க எண்ணிக்கையை மதிப்பிடவும். பக்க எண்ணிக்கை மதிப்பீட்டாளர் எளிய உள்ளீட்டிலிருந்து உடனடியாக முடிவைத் தரும்.
- பாட்டை பிட் வீதமாக மாற்றும் கணிப்பான் பாட் வீதம் மற்றும் ஒரு சின்னத்திற்கான பிட்களிலிருந்து பிட் வீதத்தைக் கணக்கிடவும். பாட்டை பிட் வீதமாக மாற்றும் கணிப்பான் ஒரு எளிய உள்ளீட்டிலிருந்து உடனடியாக முடிவைத் தருகிறது.
- பிட்வாரி AND OR XOR கணிப்பான் இரண்டு எதிர்மறையற்ற முழு எண்களின் பிட்வாரி AND, OR மற்றும் XOR ஐக் கணக்கிடுங்கள்; XOR இரும வடிவிலும் காட்டப்படும்.
- பிலிப்ஸ் சைஃபர் என்கோடர்/டிகோடர் பிலிப்ஸ் சைஃபர் மூலம் உரையை என்கோட் அல்லது டிகோட் செய்யுங்கள்; இது ஒவ்வொரு ஐந்தெழுத்து தொகுதியிலும் மாறிமாறி வரும் எட்டு திறவுகோல் 5×5 பாலிபியஸ் சதுரங்களைப் பயன்படுத்துகிறது.
- முக்கோண நிறக் கணிப்பான் எந்த hex நிறத்திற்கும் இரண்டு முக்கோண இணை நிறங்களை (நிறச் சக்கரத்தில் நிறம் ±120°) கண்டறிந்து முழு மூன்று நிற தட்டையைப் பெறுங்கள்.
- லெவன்ஷ்டீன் தூரம் கால்குலேட்டர் இரண்டு சரங்களுக்கு இடையிலான லெவன்ஷ்டீன் திருத்த தூரத்தையும் அவற்றின் ஒற்றுமை சதவீதத்தையும் கணக்கிடுங்கள்.
- வலை-பாதுகாப்பு நிற பொருத்தி ஒரு hex நிறத்தின் ஒவ்வொரு RGB சேனலையும் அருகிலுள்ள வலை-பாதுகாப்பு மதிப்பிற்கு (0, 51, 102, 153, 204, 255) வட்டமிட்டு பொருந்தும் hex குறியீட்டைத் தருகிறது.
- வேர்டுகளை பைட்டுகளாக மாற்றி தேர்ந்தெடுக்கக்கூடிய 16, 32 அல்லது 64 பிட் வேர்ட் அளவுக்கு இயந்திர வேர்டுகளுக்கும் பைட்டுகளுக்கும் இடையே இரு திசைகளிலும் மாற்றுகிறது.
- Bech32 குறியாக்கி படிக்கக்கூடிய முன்னொட்டு மற்றும் witness நிரலின் hex பைட்டுகளை செக்சம் கொண்ட bech32 சரமாக (BIP173) குறியாக்கவும்.
- BSD செக்சம் கணிப்பான் உள்ளீட்டு உரையின் பாரம்பரிய BSD sum-16 செக்சம்மை (Unix sum கட்டளை பயன்படுத்தும் 16-பிட் சுழற்று-மற்றும்-கூட்டு அல்காரிதம்) தசம மற்றும் பதின்அறும முறையில் கணக்கிடுகிறது.
- Crontab அடுத்த இயக்க கணிப்பான் நிலையான 5-புலம் crontab வெளிப்பாட்டைப் பகுத்து, அடிப்படை நேரத்திற்குப் பிறகு (UTC) திட்டமிடப்பட்ட அடுத்த இயக்க நேரங்களைப் பட்டியலிடுகிறது.
- Dvorak பதிலீட்டு மாற்றி அதே இயற்பியல் விசைகள் மற்றொரு விசைப்பலகை அமைப்பில் அழுத்தப்பட்டது போல உரையை மாற்றுகிறது, ஒவ்வொரு எழுத்தையும் QWERTY மற்றும் Dvorak விசை நிலைகளுக்கு இடையே வரைபடமாக்குகிறது.
- JSON அணியிலிருந்து NDJSON மாற்றி ஒரு JSON அணியை புதிய வரியால் பிரிக்கப்பட்ட JSON (NDJSON) ஆக மாற்றவும்; ஸ்ட்ரீமிங், பதிவுகள் மற்றும் தரவுக் குழாய்களுக்காக ஒரு வரிக்கு ஒரு சுருக்கமான JSON மதிப்பை வழங்குகிறது.
- Pig Latin மொழிபெயர்ப்பாளர் தொடக்க மெய்யெழுத்துகளை நகர்த்தி சரியான முடிவைச் சேர்த்து ஆங்கில உரையை Pig Latin ஆக மொழிபெயர்க்கவும்.
- Regex எஸ்கேப் கருவி உங்கள் உரையில் உள்ள வழக்கமான வெளிப்பாடு (regex) மெட்டா எழுத்துகள் ஒவ்வொன்றுக்கும் முன் பேக்ஸ்லாஷ் சேர்த்து எஸ்கேப் செய்கிறது, இதனால் சரம் சொல்லுக்குச் சொல் பொருந்தும்.
- ROT13/ROT5 கருவி ஒரே மாற்றத்தில் எழுத்துகளுக்கு ROT13 மற்றும் இலக்கங்களுக்கு ROT5 பயன்படுத்துகிறது — புதிர் மற்றும் மறைப்புக்கான பொதுவான மறைக்குறியீடு. ஒரே கிளிக்கில் முடிவை நகலெடுக்கவும்.
- Title Case மாற்றி எந்த உரையையும் சரியான ஆங்கில title case ஆக மாற்றுங்கள்; 'of', 'the' போன்ற சிறிய சொற்கள் சிறிய எழுத்திலேயே இருக்கும்.
- VAT எண் சரிபார்ப்பான் ஒரு EU VAT எண்ணின் வடிவத்தை நாட்டு முன்னொட்டு மற்றும் தேவையான நீளத்துடன் சரிபார்க்கிறது (DE, FR, IT, ES, NL), ஜெர்மன் செக்சம் குறிப்புடன். வடிவச் சரிபார்ப்பு மட்டுமே — நேரடி பதிவேட்டு தேடல் அல்ல.
- yEnc டிகோடர் yEnc-இல் குறியாக்கப்பட்ட சரத்தை மீண்டும் உரையாக (அல்லது பைனரிக்கு hex ஆக) டிகோடு செய்கிறது. எளிமைப்படுத்தப்பட்டது: =எஸ்கேப்பைக் கையாளுகிறது ஆனால் =ybegin/=ypart/=yend தலைப்புகளை அல்ல.