Developer & Text Tools

239 tools · page 4 of 4

  • IDN Punycode कन्वर्टर एक अंतरराष्ट्रीयकृत डोमेन नाम को Unicode और ASCII Punycode (xn--) रूप के बीच दोनों दिशाओं में बदलें।
  • फ़ाइल हस्ताक्षर (मैजिक नंबर) खोज किसी फ़ाइल के अग्रणी मैजिक-नंबर बाइट्स से उसके प्रारूप की पहचान करता है, हेक्स हस्ताक्षर को सामान्य छवि, संग्रह, दस्तावेज़ और निष्पादन योग्य प्रकारों से मिलाता है।
  • लीडिंग ज़ीरो काउंटर चुनी गई बिट चौड़ाई के लिए किसी अहस्ताक्षरित पूर्णांक के लीडिंग ज़ीरो बिट्स (CLZ) गिनता है।
  • स्वीडिश Personnummer सत्यापक पहले नौ अंकों (YYMMDD-NNN) पर Luhn चेकसम चलाकर और अंतिम चेक अंक से तुलना करके स्वीडिश Personnummer को सत्यापित करता है। विभाजक स्वतः हटा दिए जाते हैं।
  • रंग नाम से HEX परिवर्तक एक मानक CSS रंग नाम को उसके HEX कोड और RGB मान में परिवर्तित करता है।
  • Base64 आकार कैलकुलेटर डेटा को Base64 के रूप में एनकोड करते समय एनकोडेड आकार और अतिरिक्त भार निकालें।
  • Camel Case कन्वर्टर किसी भी वाक्यांश को स्पेस, अंडरस्कोर, हाइफ़न और विराम चिह्नों पर विभाजित करके camelCase और PascalCase में बदलें।
  • IEEE 754 सिंगल डिकोडर 8 हेक्साडेसिमल अंकों से 32-बिट IEEE 754 सिंगल-प्रिसिज़न फ्लोट को डिकोड करता है; मान के साथ चिह्न, घातांक और मैंटिसा फ़ील्ड दिखाता है।
  • IPv6 कंप्रेस कैलकुलेटर पूरी तरह विस्तारित IPv6 पते को आरंभिक शून्य हटाकर और शून्य समूहों की सबसे लंबी श्रृंखला को :: में संक्षिप्त करके संपीड़ित करता है।
  • वाइल्डकार्ड मास्क कैलकुलेटर डॉटेड-डेसिमल सबनेट मास्क को उसके व्युत्क्रम वाइल्डकार्ड मास्क में बदलें, जैसा कि Cisco ACL और OSPF में उपयोग होता है। प्रत्येक ऑक्टेट 255 घटा मास्क ऑक्टेट बन जाता है।
  • हैमिंग वेट कैलकुलेटर दशमलव, हेक्साडेसिमल या बाइनरी में दर्ज किए गए किसी अऋणात्मक पूर्णांक में सेट बिट (1) की संख्या गिनता है। इसे पॉपुलेशन काउंट (popcount) भी कहते हैं।
  • Base85 RFC 1924 एनकोडर 85 से बार-बार भाग देकर RFC 1924 वर्णमाला का उपयोग करते हुए एक गैर-ऋणात्मक पूर्णांक को Base85 स्ट्रिंग में एनकोड करता है।
  • CSV से Markdown तालिका परिवर्तक अल्पविराम या अर्धविराम से अलग किए गए CSV डेटा को चयन योग्य स्तंभ संरेखण के साथ एक स्वरूपित Markdown तालिका में बदलता है।
  • GTIN-14 चेक अंक कैलकुलेटर GTIN-14 के पहले 13 अंकों से GS1 mod-10 चेक अंक की गणना करता है और पूरा 14-अंकीय कोड लौटाता है।
  • HTML टैग हटाने का टूल सभी HTML टैग हटाता है और एंटिटी डिकोड करता है, साफ़ सादा टेक्स्ट और वर्ण गणना लौटाता है।
  • JSON से XML कनवर्टर एक सरल JSON ऑब्जेक्ट को सुंदर ढंग से फ़ॉर्मैट किए गए XML में बदलता है, हर key को एक एलिमेंट में बदलता है और चाइल्ड ऑब्जेक्ट्स को नेस्ट करता है, सब कुछ एक रूट टैग में लपेटकर।
  • Umask कैलकुलेटर किसी umask मान को उन डिफ़ॉल्ट अनुमतियों में बदलें जो यह नई फ़ाइलों (666 & ~umask) और डायरेक्टरियों (777 & ~umask) के लिए बनाता है।
  • बैंडविड्थ-विलंब गुणनफल कैलकुलेटर लिंक बैंडविड्थ और राउंड-ट्रिप समय से बैंडविड्थ-विलंब गुणनफल (इष्टतम TCP विंडो) निकालें।
  • होमोफोनिक प्रतिस्थापन सिफर एक सरलीकृत शैक्षिक होमोफोनिक प्रतिस्थापन योजना से पाठ को एन्कोड करता है, जहाँ एक ही अक्षर अपनी स्थिति के अनुसार भिन्न 2-अंकीय कोडों से मैप होता है।
  • NDJSON से JSON ऐरे कन्वर्टर न्यूलाइन-सीमांकित JSON (प्रति पंक्ति एक ऑब्जेक्ट) को पार्स करता है और पंक्तियों को एक सुव्यवस्थित JSON ऐरे में जोड़ता है।
  • WHOIS फ़ील्ड संदर्भ खोजें कि किसी डोमेन WHOIS रिकॉर्ड में कोई फ़ील्ड क्या मतलब रखता है, जैसे निर्माण तिथि, रजिस्ट्रार, नेम सर्वर या डोमेन स्थिति।
  • डिफी-हेलमैन कुंजी कैलकुलेटर एक अभाज्य, जनरेटर और दो निजी कुंजियों से डिफी-हेलमैन साझा रहस्य और सार्वजनिक कुंजियों की गणना करता है।
  • CONSTANT_CASE कन्वर्टर किसी भी टेक्स्ट या आइडेंटिफायर को स्पेस, हाइफ़न और camelCase सीमाओं पर विभाजित करके, फिर बड़े अक्षरों वाले शब्दों को अंडरस्कोर से जोड़कर CONSTANT_CASE में बदलें।
  • Punycode कन्वर्टर RFC 3492 bootstring एल्गोरिद्म का उपयोग करके एक Unicode डोमेन लेबल को उसके Punycode (xn--) रूप में एन्कोड करता है।
  • VIC साइफर (स्ट्रैडलिंग चेकरबोर्ड) एनकोडर स्ट्रैडलिंग चेकरबोर्ड से टेक्स्ट एनकोड करता है, जो VIC साइफर का प्रतिस्थापन केंद्र है। सरलीकृत: इसमें चेन जोड़ और स्थानांतरण शामिल नहीं है, इसलिए यह पूर्ण VIC साइफर नहीं है।
  • इंटरनेट चेकसम कैलकुलेटर हेक्साडेसिमल डेटा का 16-बिट इंटरनेट चेकसम (RFC 1071) गणना करें — एक-का-पूरक योग जो IP, TCP और UDP हेडर में उपयोग होता है। हेडर चेकसम सत्यापित या उत्पन्न करें।
  • एक्सेंट हटाने का टूल टेक्स्ट से एक्सेंट और डायाक्रिटिक चिह्न हटाएँ और é, ü और ñ जैसे अक्षरों को सादे ASCII में बदलें।
  • क्रॉन एक्सप्रेशन व्याख्याकार 5-फ़ील्ड वाले क्रॉन एक्सप्रेशन (मिनट घंटा महीने का दिन महीना सप्ताह का दिन) को पार्स करता है और सरल भाषा में बताता है कि यह कब चलेगा।
  • चेकरबोर्ड पॉलीबियस वेरिएंट टूल कीवर्ड-मिश्रित पॉलीबियस वर्ग (एक चेकरबोर्ड वेरिएंट) के साथ टेक्स्ट को एन्कोड या डिकोड करता है, अक्षरों को पंक्ति/स्तंभ अंक युग्मों से मैप करता है।
  • टाइटल केस कन्वर्टर किसी भी अंग्रेज़ी टेक्स्ट को सही टाइटल केस में बदलें; 'of' और 'the' जैसे छोटे शब्द छोटे अक्षरों में रहते हैं।
  • टैप कोड अनुवादक टेक्स्ट को टैप कोड में और उससे वापस बदलता है, जो कैदियों द्वारा प्रयुक्त 5x5 पॉलीबियस खटखट सिफर है।
  • टैली चिह्न परिवर्तक किसी पूर्ण संख्या को टैली चिह्नों में बदलता है, प्रत्येक पांच को एक क्रॉस किए गए समूह प्रतीक के साथ समूहित करता है।
  • ट्रायडिक रंग कैलकुलेटर किसी भी hex रंग के लिए दो ट्रायडिक साथी रंग (कलर व्हील पर ह्यू ±120°) खोजें और पूरा तीन-रंग पैलेट पाएँ।
  • पासफ़्रेज़ जेनरेटर एक बीज से नियतात्मक रूप से याद रखने योग्य शब्द-आधारित पासफ़्रेज़ बनाता है, ताकि वही बीज हमेशा वही वाक्यांश दे। अनुमानित एंट्रॉपी बताता है।
  • पासवर्ड सुरक्षा कैलकुलेटर आपके पासवर्ड के कैरेक्टर सेट से उसकी एंट्रॉपी और ब्रूट फोर्स विधि से उसे क्रैक करने में लगने वाले अनुमानित समय का पता लगाना।
  • पूरक रंग कैलकुलेटर HSL में रंग को 180° घुमाकर किसी hex मान का पूरक रंग खोजता है, और RGB-इनवर्ट विकल्प भी देता है।
  • पृष्ठ संख्या अनुमानक शब्द गणना से पृष्ठ संख्या का अनुमान लगाएं। पृष्ठ संख्या अनुमानक एक सरल इनपुट से तुरंत परिणाम देता है।
  • फिलिप्स सिफर एनकोडर/डिकोडर फिलिप्स सिफर से टेक्स्ट एनकोड या डिकोड करें, जो हर पाँच-अक्षर ब्लॉक में बारी-बारी आठ कुंजीयुक्त 5×5 पॉलीबियस वर्गों का उपयोग करता है।
  • फ़ोन कीपैड अनुवादक अक्षरों को टेलीफ़ोन कीपैड के अंकों (ABC=2 ... WXYZ=9) में बदलता है, ताकि आप अक्षर वाला फ़ोन नंबर डायल कर सकें।
  • बिटवाइज AND OR XOR कैलकुलेटर दो अऋणात्मक पूर्णांकों का बिटवाइज AND, OR और XOR निकालें, जिसमें XOR द्विआधारी में दिखाया जाता है।
  • बॉड से बिटरेट कैलकुलेटर बॉड दर और प्रति प्रतीक बिट्स से बिट दर गणना करें। बॉड से बिटरेट कैलकुलेटर एक सरल इनपुट से आपको परिणाम तुरंत देता है।
  • मॉकिंग केस टेक्स्ट जनरेटर आपके टेक्स्ट को बारी-बारी से बड़े और छोटे अक्षरों के साथ SpongeBob मॉकिंग मीम शैली में परिवर्तित करता है।
  • लेवेनश्टाइन दूरी कैलकुलेटर दो स्ट्रिंग्स के बीच लेवेनश्टाइन एडिट दूरी और उनकी समानता का प्रतिशत निकालें।
  • वर्ड से बाइट कनवर्टर चयन योग्य 16, 32 या 64 बिट वर्ड आकार के लिए मशीन वर्ड और बाइट के बीच दोनों दिशाओं में रूपांतरण करता है।
  • वेब-सेफ कलर स्नैपर किसी hex रंग के प्रत्येक RGB चैनल को निकटतम वेब-सेफ मान (0, 51, 102, 153, 204, 255) पर राउंड करता है और मेल खाता hex कोड लौटाता है।
  • वैट नंबर सत्यापक किसी ईयू वैट नंबर के प्रारूप को देश के उपसर्ग और आवश्यक लंबाई के विरुद्ध जांचता है (DE, FR, IT, ES, NL), जर्मन चेकसम टिप्पणी के साथ। केवल प्रारूप जांच — लाइव रजिस्ट्री खोज नहीं।
  • शब्द आवृत्ति काउंटर गिनें कि टेक्स्ट में हर शब्द कितनी बार आता है, सबसे अधिक से सबसे कम के क्रम में।
  • सिमेंटिक वर्शन वैलिडेटर जाँचें कि कोई स्ट्रिंग वैध Semantic Versioning 2.0.0 संस्करण है या नहीं और उसके major, minor, patch, प्री-रिलीज़ और build भागों को अलग करें।
  • स्पेस से टैब कनवर्टर आपके द्वारा निर्धारित चौड़ाई पर प्रत्येक पंक्ति के शुरुआती स्पेस को टैब वर्णों में बदलता है, पंक्ति दर पंक्ति।
  • स्वर और व्यंजन गणक पाठ में स्वर और व्यंजन गिनें। स्वर और व्यंजन गणक एक सरल इनपुट से तुरंत परिणाम देता है।
  • Bech32 एन्कोडर एक पठनीय उपसर्ग और witness प्रोग्राम के hex बाइट्स को चेकसम युक्त bech32 स्ट्रिंग (BIP173) में एन्कोड करें।
  • BSD चेकसम कैलकुलेटर इनपुट टेक्स्ट के क्लासिक BSD sum-16 चेकसम (Unix sum कमांड द्वारा प्रयुक्त 16-बिट घुमाओ-और-जोड़ो एल्गोरिथम) की गणना दशमलव और हेक्साडेसिमल में करता है।
  • Crontab अगला रन कैलकुलेटर एक मानक 5-फ़ील्ड crontab अभिव्यक्ति को पार्स करता है और एक आधार समय (UTC) के बाद के अगले निर्धारित रन समयों की सूची देता है।
  • Dvorak प्रतिस्थापन कन्वर्टर टेक्स्ट को इस तरह परिवर्तित करता है जैसे वही भौतिक कुंजियाँ दूसरे कीबोर्ड लेआउट पर दबाई गई हों, प्रत्येक अक्षर को QWERTY और Dvorak कुंजी स्थितियों के बीच मैप करता है।
  • JSON ऐरे से NDJSON कन्वर्टर एक JSON ऐरे को न्यूलाइन-सीमांकित JSON (NDJSON) में बदलें, स्ट्रीमिंग, लॉग और डेटा पाइपलाइनों के लिए प्रति पंक्ति एक संक्षिप्त JSON मान निकालते हुए।
  • Pig Latin अनुवादक अंग्रेज़ी टेक्स्ट को Pig Latin में बदलें, आरंभिक व्यंजनों को हटाकर सही अंत जोड़ें।
  • Regex एस्केप टूल आपके टेक्स्ट में नियमित अभिव्यक्ति (regex) के मेटा वर्णों के आगे बैकस्लैश जोड़कर उन्हें एस्केप करता है, ताकि स्ट्रिंग शाब्दिक रूप से मेल खाए।
  • ROT13/ROT5 संयोजन उपकरण एक ही रूपांतरण में अक्षरों पर ROT13 और अंकों पर ROT5 लागू करें, पहेली और अस्पष्टीकरण के लिए एक सामान्य सिफर। परिणाम एक क्लिक में कॉपी करें।
  • yEnc डिकोडर yEnc-एन्कोडेड स्ट्रिंग को वापस टेक्स्ट में (या बाइनरी के लिए hex में) डिकोड करें। सरलीकृत: =एस्केप संभालता है लेकिन =ybegin/=ypart/=yend हेडर नहीं।