Developer & Text Tools
239 tools · page 4 of 4
- Μετατροπέας IDN Punycode Μετατρέψτε ένα διεθνοποιημένο όνομα τομέα μεταξύ μορφής Unicode και ASCII Punycode (xn--) και προς τις δύο κατευθύνσεις.
- Αναζήτηση Υπογραφής Αρχείου (Magic Number) Αναγνωρίζει τη μορφή ενός αρχείου από τα αρχικά bytes magic-number, αντιστοιχίζοντας τη δεκαεξαδική υπογραφή με κοινούς τύπους εικόνας, αρχειοθήκης, εγγράφου και εκτελέσιμων.
- Επικυρωτής σουηδικού Personnummer Επικυρώνει ένα σουηδικό Personnummer εκτελώντας το άθροισμα ελέγχου Luhn στα πρώτα εννέα ψηφία (YYMMDD-NNN) και συγκρίνοντάς το με το τελευταίο ψηφίο ελέγχου. Οι διαχωριστές αφαιρούνται αυτόματα.
- Μετρητής Αρχικών Μηδενικών Μετρά τα αρχικά μηδενικά bits (CLZ) ενός απρόσημου ακεραίου για επιλεγμένο εύρος bit.
- Αποκωδικοποιητής IEEE 754 single Αποκωδικοποιεί έναν αριθμό κινητής υποδιαστολής μονής ακρίβειας 32-bit IEEE 754 από 8 δεκαεξαδικά ψηφία, εμφανίζοντας την τιμή μαζί με τα πεδία πρόσημου, εκθέτη και μάντισσας.
- Μετατροπέας Ονόματος Χρώματος σε HEX Μετατρέπει ένα τυπικό όνομα χρώματος CSS στον κωδικό HEX και την τιμή RGB του.
- Μετατροπέας Camel Case Μετατρέψτε οποιαδήποτε φράση σε camelCase και PascalCase χωρίζοντάς την σε κενά, κάτω παύλες, παύλες και σημεία στίξης.
- Υπολογιστής μεγέθους Base64 Υπολογίστε το κωδικοποιημένο μέγεθος και την επιβάρυνση κατά την κωδικοποίηση δεδομένων ως Base64.
- Υπολογιστής συμπίεσης IPv6 Συμπιέζει μια πλήρως αναπτυγμένη διεύθυνση IPv6 αφαιρώντας τα αρχικά μηδενικά και συμπτύσσοντας τη μεγαλύτερη ακολουθία ομάδων μηδενικών σε ::.
- Υπολογιστής βάρους Hamming Μετράει το πλήθος των ενεργών bit (μονάδων) σε έναν μη αρνητικό ακέραιο που εισάγεται σε δεκαδικό, δεκαεξαδικό ή δυαδικό σύστημα. Λέγεται επίσης population count ή popcount.
- Υπολογιστής Wildcard Mask Μετατρέψτε μια μάσκα υποδικτύου σε δεκαδική μορφή με τελείες στην αντίστροφη wildcard mask, όπως χρησιμοποιείται σε Cisco ACL και OSPF. Κάθε οκτάδα γίνεται 255 μείον την οκτάδα της μάσκας.
- Κωδικοποιητής Base85 RFC 1924 Κωδικοποιεί έναν μη αρνητικό ακέραιο σε συμβολοσειρά Base85 χρησιμοποιώντας το αλφάβητο RFC 1924 με επαναλαμβανόμενη διαίρεση με το 85.
- Μετατροπέας CSV σε Πίνακα Markdown Μετατρέπει δεδομένα CSV χωρισμένα με κόμμα ή ερωτηματικό σε μορφοποιημένο πίνακα Markdown με επιλέξιμη στοίχιση στηλών.
- Υπολογιστής Ψηφίου Ελέγχου GTIN-14 Υπολογίζει το ψηφίο ελέγχου GS1 mod-10 για έναν κωδικό GTIN-14 από τα πρώτα 13 ψηφία του και επιστρέφει τον πλήρη 14ψήφιο κωδικό.
- Εργαλείο Αφαίρεσης Ετικετών HTML Αφαιρεί όλες τις ετικέτες HTML και αποκωδικοποιεί τις οντότητες, επιστρέφοντας καθαρό απλό κείμενο και πλήθος χαρακτήρων.
- Μετατροπέας JSON σε XML Μετατρέπει ένα απλό αντικείμενο JSON σε όμορφα μορφοποιημένο XML, μετατρέποντας κάθε κλειδί σε στοιχείο και ενσωματώνοντας τα θυγατρικά αντικείμενα, τυλιγμένα σε μια ρίζα ετικέτα.
- Υπολογιστής umask Μετατρέψτε μια τιμή umask στα προεπιλεγμένα δικαιώματα που παράγει για νέα αρχεία (666 & ~umask) και καταλόγους (777 & ~umask).
- Αναφορά Πεδίων WHOIS Αναζητήστε τι σημαίνει ένα πεδίο σε μια εγγραφή WHOIS ενός τομέα, όπως ημερομηνία δημιουργίας, καταχωρητής, διακομιστής ονομάτων ή κατάσταση τομέα.
- Μετατροπέας NDJSON σε πίνακα JSON Αναλύει JSON διαχωρισμένο ανά γραμμή (ένα αντικείμενο ανά γραμμή) και συνδυάζει τις γραμμές σε έναν ενιαίο, καλομορφοποιημένο πίνακα JSON.
- Ομοφωνικός κρυπτογράφος αντικατάστασης Κωδικοποιεί κείμενο με ένα απλοποιημένο εκπαιδευτικό σχήμα ομοφωνικής αντικατάστασης, όπου το ίδιο γράμμα αντιστοιχίζεται σε διαφορετικούς διψήφιους κωδικούς ανάλογα με τη θέση του.
- Υπολογιστής γινομένου εύρους ζώνης × καθυστέρησης (BDP) Υπολογίστε το γινόμενο εύρους ζώνης × καθυστέρησης (βέλτιστο παράθυρο TCP) από το εύρος ζώνης της σύνδεσης και τον χρόνο μετ' επιστροφής.
- Κωδικοποιητής κρυπτογράφησης VIC (διαζευγμένη σκακιέρα) Κωδικοποιεί κείμενο με διαζευγμένη σκακιέρα, τον πυρήνα υποκατάστασης της κρυπτογράφησης VIC. Απλοποιημένο: παραλείπει την αλυσιδωτή πρόσθεση και τη μετάθεση, οπότε δεν είναι η πλήρης κρυπτογράφηση VIC.
- Μετατροπέας CONSTANT_CASE Μετατρέψτε οποιοδήποτε κείμενο ή αναγνωριστικό σε CONSTANT_CASE χωρίζοντάς το σε κενά, παύλες και όρια camelCase και έπειτα ενώνοντας τις κεφαλαιοποιημένες λέξεις με κάτω παύλες.
- Μετατροπέας Punycode Κωδικοποιεί μία ετικέτα τομέα Unicode στη μορφή Punycode (xn--) χρησιμοποιώντας τον αλγόριθμο bootstring του RFC 3492.
- Υπολογισμός Κλειδιού Diffie-Hellman Υπολογίζει το κοινό μυστικό και τα δημόσια κλειδιά Diffie-Hellman από έναν πρώτο, μια γεννήτρια και δύο ιδιωτικά κλειδιά.
- Αποκωδικοποιητής yEnc Αποκωδικοποιεί μια συμβολοσειρά κωδικοποιημένη με yEnc πίσω σε κείμενο (ή hex για δυαδικά δεδομένα). Απλοποιημένο: υποστηρίζει το =escape αλλά όχι τις κεφαλίδες =ybegin/=ypart/=yend.
- Γεννήτρια Κειμένου Mocking Case Μετατρέπει το κείμενό σας στο στυλ του meme mocking SpongeBob με εναλλασσόμενα κεφαλαία και πεζά γράμματα.
- Γεννήτρια φράσης πρόσβασης Δημιουργεί μια εύκολα απομνημονεύσιμη φράση πρόσβασης βασισμένη σε λέξεις ντετερμινιστικά από έναν σπόρο, ώστε ο ίδιος σπόρος να δίνει πάντα την ίδια φράση. Αναφέρει την εκτιμώμενη εντροπία.
- Εκτιμητής Αριθμού Σελίδων Εκτιμήστε τον αριθμό σελίδων από έναν αριθμό λέξεων. Ο Εκτιμητής Αριθμού Σελίδων σάς δίνει το αποτέλεσμα άμεσα από μια απλή εισαγωγή.
- Επεξηγητής έκφρασης cron Αναλύει μια έκφραση cron 5 πεδίων (λεπτό ώρα ημέρα μήνα μήνας ημέρα εβδομάδας) και περιγράφει σε απλά λόγια πότε εκτελείται.
- Επικυρωτής αριθμού ΦΠΑ Ελέγχει τη μορφή ενός αριθμού ΦΠΑ της ΕΕ σε σχέση με το πρόθεμα της χώρας και το απαιτούμενο μήκος (DE, FR, IT, ES, NL), με σημείωση για το γερμανικό άθροισμα ελέγχου. Μόνο έλεγχος μορφής — όχι αναζήτηση σε ζωντανό μητρώο.
- Επικυρωτής Σημασιολογικής Έκδοσης Ελέγξτε αν μια συμβολοσειρά είναι έγκυρη έκδοση Semantic Versioning 2.0.0 και αναλύστε τα τμήματα major, minor, patch, pre-release και build.
- Εργαλείο Αφαίρεσης Τόνων Αφαιρέστε τόνους και διακριτικά σημάδια από κείμενο, μετατρέποντας γράμματα όπως é, ü και ñ σε απλό ASCII.
- Εργαλείο Παραλλαγής Πολύβιου Σκακιέρας Κωδικοποιεί ή αποκωδικοποιεί κείμενο με ένα τετράγωνο Πολύβιου αναμεμειγμένο με λέξη-κλειδί (παραλλαγή σκακιέρας), αντιστοιχίζοντας γράμματα σε ζεύγη ψηφίων γραμμής/στήλης.
- Εργαλείο Συνδυασμού ROT13/ROT5 Εφαρμόστε ROT13 στα γράμματα και ROT5 στα ψηφία σε έναν μετασχηματισμό, έναν συνηθισμένο κρυπτογράφο γρίφων και απόκρυψης. Αντιγράψτε το αποτέλεσμα με ένα κλικ.
- Εργαλείο Escape για Regex Κάνει escape τους μεταχαρακτήρες κανονικών εκφράσεων (regex) στο κείμενό σας προσθέτοντας μια ανάποδη κάθετο πριν από καθέναν, ώστε η συμβολοσειρά να ταιριάζει κυριολεκτικά.
- Κωδικοποιητής Bech32 Κωδικοποιήστε ένα αναγνώσιμο πρόθεμα και hex bytes προγράμματος witness σε συμβολοσειρά bech32 με άθροισμα ελέγχου (BIP173).
- Κωδικοποιητής/Αποκωδικοποιητής Phillips Κωδικοποιήστε ή αποκωδικοποιήστε κείμενο με το κρυπτογράφημα Phillips, που χρησιμοποιεί οκτώ κλειδωμένα τετράγωνα Polybius 5×5 εναλλασσόμενα σε κάθε μπλοκ πέντε γραμμάτων.
- Μετατροπέας αντικατάστασης Dvorak Μετατρέπει το κείμενο σαν να πατήθηκαν τα ίδια φυσικά πλήκτρα στην άλλη διάταξη πληκτρολογίου, αντιστοιχίζοντας κάθε γράμμα μεταξύ των θέσεων πλήκτρων QWERTY και Dvorak.
- Μετατροπέας Γραμμών Καταμέτρησης Μετατρέπει έναν ακέραιο αριθμό σε γραμμές καταμέτρησης, ομαδοποιώντας ανά πέντε με ένα διαγραμμισμένο σύμβολο ομάδας.
- Μετατροπέας κενών σε στηλοθέτες Μετατρέπει κάθε ακολουθία αρχικών κενών στο πλάτος που ορίζετε σε χαρακτήρες στηλοθέτη, γραμμή προς γραμμή.
- Μετατροπέας λέξεων σε bytes Μετατρέπει μεταξύ λέξεων μηχανής και bytes για επιλέξιμο μέγεθος λέξης 16, 32 ή 64 bit, και προς τις δύο κατευθύνσεις.
- Μετατροπέας πίνακα JSON σε NDJSON Μετατρέψτε έναν πίνακα JSON σε JSON οριοθετημένο με νέες γραμμές (NDJSON), εξάγοντας μία συμπαγή τιμή JSON ανά γραμμή για streaming, αρχεία καταγραφής και αγωγούς δεδομένων.
- Μετατροπέας Title Case Μετατρέψτε οποιοδήποτε αγγλικό κείμενο σε σωστό title case, με μικρές λέξεις όπως 'of' και 'the' να μένουν πεζές.
- Μεταφραστής Κώδικα Χτυπημάτων Μετατρέπει κείμενο από και προς τον κώδικα χτυπημάτων, την κρυπτογράφηση Polybius 5x5 που χρησιμοποιούσαν οι κρατούμενοι.
- Μεταφραστής Πληκτρολογίου Τηλεφώνου Μετατρέπει τα γράμματα στα ψηφία ενός τηλεφωνικού πληκτρολογίου (ABC=2 ... WXYZ=9), ώστε να μπορείτε να καλέσετε έναν αριθμό με γράμματα.
- Μεταφραστής Pig Latin Μεταφράστε αγγλικό κείμενο σε Pig Latin, μετακινώντας τα αρχικά σύμφωνα και προσθέτοντας τη σωστή κατάληξη.
- Μετρητής Συχνότητας Λέξεων Μετρήστε πόσο συχνά εμφανίζεται κάθε λέξη σε ένα κείμενο, ταξινομημένες από τις πιο συχνές στις λιγότερο συχνές.
- Μετρητής Φωνηέντων και Συμφώνων Μετρήστε τα φωνήεντα και τα σύμφωνα σε ένα κείμενο. Ο Μετρητής Φωνηέντων και Συμφώνων σάς δίνει το αποτέλεσμα άμεσα από μια απλή εισαγωγή.
- Προσαρμογή ασφαλών χρωμάτων ιστού Στρογγυλοποιεί κάθε κανάλι RGB ενός hex χρώματος στην πλησιέστερη ασφαλή για το web τιμή (0, 51, 102, 153, 204, 255) και επιστρέφει τον αντίστοιχο κωδικό hex.
- Υπολογιστής αθροίσματος ελέγχου BSD Υπολογίζει το κλασικό άθροισμα ελέγχου BSD sum-16 του κειμένου εισόδου (ο 16-bit αλγόριθμος περιστροφής-και-πρόσθεσης που χρησιμοποιεί η εντολή sum του Unix), σε δεκαδική και δεκαεξαδική μορφή.
- Υπολογιστής Αθροίσματος Ελέγχου Internet Υπολογίστε το 16-bit άθροισμα ελέγχου Internet (RFC 1071) δεδομένων δεκαεξαδικής μορφής — το άθροισμα συμπληρώματος ως προς ένα που χρησιμοποιείται στις κεφαλίδες IP, TCP και UDP. Επαληθεύστε ή δημιουργήστε αθροίσματα ελέγχου κεφαλίδων.
- Υπολογιστής Απόστασης Λέβενσταϊν Υπολογίστε την απόσταση επεξεργασίας Λέβενσταϊν μεταξύ δύο συμβολοσειρών και το ποσοστό ομοιότητάς τους.
- Υπολογιστής Επόμενης Εκτέλεσης Crontab Αναλύει μια τυπική έκφραση crontab 5 πεδίων και παραθέτει τις επόμενες προγραμματισμένες ώρες εκτέλεσης μετά από έναν χρόνο βάσης (UTC).
- Υπολογιστής Ισχύος Κωδικού Πρόσβασης Εντροπία του κωδικού πρόσβασής σας από το σύνολο χαρακτήρων του και μια εκτίμηση του χρόνου που απαιτείται για την παραβίασή του με ωμή βία.
- Υπολογιστής συμπληρωματικού χρώματος Βρίσκει το συμπληρωματικό χρώμα μιας τιμής hex περιστρέφοντας την απόχρωση κατά 180° στο HSL και δίνει επίσης την εναλλακτική αντιστροφής RGB.
- Υπολογιστής Τριαδικών Χρωμάτων Βρείτε τα δύο τριαδικά χρώματα-συνεργάτες (απόχρωση ±120° στον χρωματικό τροχό) για οποιοδήποτε hex χρώμα και αποκτήστε την πλήρη τρίχρωμη παλέτα.
- Υπολογιστής Baud σε Ρυθμό Bit Υπολογίστε τον ρυθμό bit από τον ρυθμό baud και τα bit ανά σύμβολο. Ο Υπολογιστής Baud σε Ρυθμό Bit σάς δίνει το αποτέλεσμα άμεσα από μια απλή εισαγωγή.
- Υπολογιστής bitwise AND OR XOR Υπολογίστε το bitwise AND, OR και XOR δύο μη αρνητικών ακεραίων, με το XOR να εμφανίζεται σε δυαδική μορφή.