Developer & Text Tools

239 tools · page 4 of 4

  • Стваральнік Geo URI Стварае стандартны geo: URI паводле RFC 5870 з шыраты і даўгаты, з апцыянальнымі вышынёй і дакладнасцю.
  • Лічыльнік вядучых нулёў Лічыць вядучыя нулявыя біты (CLZ) бяззнакавага цэлага ліку для выбранай разраднасці.
  • Пошук сігнатуры файла (магічны нумар) Вызначае фармат файла па яго першых байтах магічнага нумара, супастаўляючы шаснаццатковую сігнатуру з распаўсюджанымі тыпамі выяў, архіваў, дакументаў і выканальных файлаў.
  • Праверка шведскага Personnummer Правярае шведскі Personnummer, выконваючы кантрольную суму Luhn па першых дзевяці лічбах (YYMMDD-NNN) і параўноўваючы з апошняй кантрольнай лічбай. Падзяляльнікі выдаляюцца аўтаматычна.
  • Дэкодэр IEEE 754 одінарны Дэкадуе 32-бітны лік з плаваючай коскай адзінарнай дакладнасці IEEE 754 з 8 шаснаццатковых лічбаў, паказваючы значэнне, а таксама палі знака, парадку і мантысы.
  • Калькулятар памеру Base64 Разлічыце закадаваны памер і прырост памеру пры кадаванні даных у Base64.
  • Калькулятар сціску IPv6 Сціскае цалкам разгорнуты адрас IPv6, выдаляючы вядучыя нулі і аб’ядноўваючы найдаўжэйшую паслядоўнасць нулявых груп у ::.
  • Канвертар назвы колеру ў HEX Пераўтварае стандартную назву колеру CSS у яе HEX-код і значэнне RGB.
  • Канвертар Camel Case Пераўтварыце любую фразу ў camelCase і PascalCase, падзяляючы яе па прабелах, падкрэсліваннях, дэфісах і знаках прыпынку.
  • Калькулятар вагі Хэмінга Падлічыце колькасць усталяваных бітаў (адзінак) у неадмоўным цэлым ліку, уведзеным у дзесятковай, шаснаццатковай або двайковай сістэме. Таксама вядома як падлік насялення (popcount).
  • Калькулятар wildcard mask Пераводзьце дзесятковую маску падсеткі ў адваротную wildcard mask, якая выкарыстоўваецца ў Cisco ACL і OSPF. Кожны актэт становіцца 255 мінус актэт маскі.
  • Кадавальнік Base85 RFC 1924 Кадзіруе неадмоўны цэлы лік у радок Base85 з выкарыстаннем алфавіту RFC 1924 шляхам шматразовага дзялення на 85.
  • Канвертар CSV у табліцу Markdown Пераўтварае дадзеныя CSV, падзеленыя коскай ці кропкай з коскай, у адфарматаваную табліцу Markdown з выбіральным выраўноўваннем слупкоў.
  • Калькулятар кантрольнай лічбы GTIN-14 Вылічвае кантрольную лічбу GS1 mod-10 для GTIN-14 з яго першых 13 лічбаў і вяртае поўны 14-значны код.
  • Інструмент выдалення HTML-тэгаў Выдаляе ўсе HTML-тэгі і дэкадуе сутнасці, вяртаючы чысты звычайны тэкст і колькасць сімвалаў.
  • Канвертар JSON у XML Пераўтварае просты аб'ект JSON у акуратна адфарматаваны XML, ператвараючы кожны ключ у элемент і ўкладваючы даччыныя аб'екты, абгортваючы ўсё ў каранёвы тэг.
  • Калькулятар umask Пераўтварыце значэнне umask у дазволы па змаўчанні, якія яно стварае для новых файлаў (666 & ~umask) і каталогаў (777 & ~umask).
  • Даведнік палёў Whois Даведайцеся, што азначае поле ў запісе WHOIS дамена, напрыклад дата стварэння, рэгістратар, сервер імёнаў або статус дамена.
  • Калькулятар здабытку прапускной здольнасці на затрымку (BDP) Разлічыце здабытак прапускной здольнасці на затрымку (аптымальнае акно TCP) па прапускной здольнасці канала і часе кругавой затрымкі.
  • Канвертар NDJSON у масіў JSON Разбірае JSON, падзелены радкамі (адзін аб'ект на радок), і аб'ядноўвае радкі ў адзін прыгожа адфарматаваны масіў JSON.
  • Шыфр гамафанічнай замены Кадзіруе тэкст спрошчанай навучальнай схемай гамафанічнай замены, дзе адна і тая ж літара адлюстроўваецца на розныя двухзначныя коды ў залежнасці ад яе пазіцыі.
  • Кадавальнік шыфра VIC (расцяжная шахматная дошка) Кадуе тэкст з дапамогай расцяжной шахматнай дошкі — ядра падстаноўкі шыфра VIC. Спрошчаны: не змяшчае ланцуговага складання і перастаноўкі, таму гэта не поўны шыфр VIC.
  • Калькулятар ключа Дыфі-Хелмана Разлічвае агульны сакрэт і адкрытыя ключы Дыфі-Хелмана з простага ліку, генератара і двух прыватных ключоў.
  • Канвертар CONSTANT_CASE Пераўтварыце любы тэкст ці ідэнтыфікатар у CONSTANT_CASE, падзяляючы яго па прабелах, дэфісах і межах camelCase, а потым злучаючы словы ў верхнім рэгістры падкрэсліваннямі.
  • Канвертар Punycode Кадзіруе адну метку дамена Unicode у форму Punycode (xn--) з дапамогай алгарытму bootstring з RFC 3492.
  • Ацэншчык колькасці старонак Ацаніце колькасць старонак з колькасці слоў. Ацэншчык колькасці старонак імгненна дае вынік з простага ўводу.
  • Валідатар семантычнай версіі Праверце, ці з'яўляецца радок сапраўднай версіяй паводле семантычнага версіянавання 2.0.0, і вылучыце яе мажорную, мінорную, патч-, перадрэлізную і зборачную часткі.
  • Генератар парольнай фразы Стварае запамінальную парольную фразу на аснове слоў дэтэрмінавана з зерня, таму адно і тое ж зерне заўсёды дае адну і тую ж фразу. Паведамляе пра ацэненую энтрапію.
  • Генератар тэксту з насмешлівым чаргаваннем рэгістра Пераўтварае ваш тэкст у стыль насмешлівага мема SpongeBob з чаргаваннем вялікіх і малых літар.
  • Дэкодэр yEnc Дэкадзіруйце радок, закадаваны ў yEnc, назад у тэкст (або hex для двайковых дадзеных). Спрошчана: падтрымлівае =экранаванне, але не загалоўкі =ybegin/=ypart/=yend.
  • Інструмент варыянту шахматнага Палібія Шыфруе ці дэшыфруе тэкст квадратам Палібія, змешаным з ключавым словам (шахматны варыянт), супастаўляючы літары парам лічбаў радка/слупка.
  • Інструмент выдалення дыякрытыкі Выдаліце акцэнты і дыякрытычныя знакі з тэксту, пераўтварыўшы літары накшталт é, ü і ñ у звычайныя ASCII.
  • Інструмент экранавання Regex Экрануе метасімвалы рэгулярных выразаў (regex) у вашым тэксце, дадаючы перад кожным зваротны слэш, каб радок супадаў літаральна.
  • Кадавальнік Bech32 Закадзіруйце чытэльны прэфікс і hex-байты witness-праграмы ў радок bech32 з кантрольнай сумай (BIP173).
  • Калькулятар адлегласці Левенштэйна Вылічыце рэдакцыйную адлегласць Левенштэйна паміж двума радкамі і працэнт іх падабенства.
  • Калькулятар бод у бітрэйт Разлічыце хуткасць у бітах па хуткасці ў бодах і бітах на сімвал. Калькулятар імгненна дае вынік з простага ўводу.
  • Калькулятар дадатковага колеру Знаходзіць дадатковы колер для hex-значэння, паварочваючы адценне на 180° у HSL, а таксама дае альтэрнатыву інверсіі RGB.
  • Калькулятар інтэрнэт-кантрольнай сумы Разлічыце 16-бітную інтэрнэт-кантрольную суму (RFC 1071) шаснаццатковых даных — суму ў адваротным кодзе, што ўжываецца ў загалоўках IP, TCP і UDP. Праверце ці згенеруйце кантрольныя сумы загалоўкаў.
  • Калькулятар кантрольнай сумы BSD Вылічае класічную кантрольную суму BSD sum-16 уведзенага тэксту (16-бітны алгарытм паварот-і-дадаць, які выкарыстоўвае каманда sum у Unix) у дзесятковым і шаснаццатковым выглядзе.
  • Калькулятар надзейнасці пароля Энтрапія вашага пароля з яго набору сімвалаў і ацэнка часу, неабходнага для яго ўзлому метадам грубай сілы.
  • Калькулятар наступнага запуску Crontab Разбірае стандартны выраз crontab з 5 палёў і пералічвае наступныя запланаваныя моманты запуску пасля базавага часу (UTC).
  • Калькулятар пабітавых AND OR XOR Вылічыце пабітавыя AND, OR і XOR двух неадмоўных цэлых лікаў, прычым XOR паказваецца ў двайковай сістэме.
  • Калькулятар трыядных колераў Знайдзіце два трыядныя колеры-партнёры (адценне ±120° на колеравым крузе) для любога hex-колеру і атрымайце поўную палітру з трох колераў.
  • Камбінаваны інструмент ROT13/ROT5 Прымяніце ROT13 да літар і ROT5 да лічбаў за адно пераўтварэнне — распаўсюджаны шыфр для галаваломак і абфускацыі. Скапіруйце вынік адным націскам.
  • Канвертар замены Dvorak Пераўтварае тэкст так, быццам тыя ж фізічныя клавішы былі націснутыя на іншай раскладцы, супастаўляючы кожную літару паміж пазіцыямі клавіш QWERTY і Dvorak.
  • Канвертар масіва JSON у NDJSON Пераўтварыце масіў JSON у JSON, падзелены пераносамі радкоў (NDJSON), выдаючы адно кампактнае значэнне JSON на радок для струменю, логаў і канвееераў даных.
  • Канвертар прабелаў у табуляцыі Пераўтварае кожную групу пачатковых прабелаў зададзенай шырыні ў сімвалы табуляцыі, радок за радком.
  • Канвертар рысак падліку Пераводзіць цэлы лік у рыскі падліку, групуючы кожныя пяць перакрэсленым сімвалам групы.
  • Канвертар слоў у байты Пераводзіць паміж машыннымі словамі і байтамі для абіранага памеру слова 16, 32 ці 64 біты ў абодвух напрамках.
  • Канвертар у Title Case Пераўтварыце любы англійскі тэкст у правільны загалоўны рэгістр: кароткія словы кшталту 'of' і 'the' застаюцца малымі літарамі.
  • Лічыльнік галосных і зычных Падлічыце галосныя і зычныя ў тэксце. Лічыльнік галосных і зычных імгненна дае вынік з простага ўводу.
  • Лічыльнік частаты слоў Падлічыце, як часта кожнае слова сустракаецца ў тэксце, адсартавана ад самага частага да самага рэдкага.
  • Падбор web-бяспечнага колеру Акругляе кожны канал RGB hex-колеру да бліжэйшага web-бяспечнага значэння (0, 51, 102, 153, 204, 255) і вяртае адпаведны hex-код.
  • Перакладчык стукальнага кода Пераўтварае тэкст у стукальны код і назад, шыфр стуку Палібія 5x5, які выкарыстоўвалі вязні.
  • Перакладчык тэлефоннай клавіятуры Пераўтварае літары ў лічбы на тэлефоннай клавіятуры (ABC=2 ... WXYZ=9), каб вы маглі набраць літарны тэлефонны нумар.
  • Перакладчык Pig Latin Перакладзіце англійскі тэкст у Pig Latin, перамяшчаючы пачатковыя зычныя і дадаючы патрэбны канчатак.
  • Праверка нумара ПДВ Правярае фармат еўрапейскага нумара ПДВ паводле прэфікса краіны і патрэбнай даўжыні (DE, FR, IT, ES, NL), з заўвагай пра нямецкую кантрольную суму. Толькі праверка фармату — не запыт у рэестр у рэальным часе.
  • Тлумачальнік выразу cron Разбірае 5-палявы выраз cron (хвіліна гадзіна дзень месяца месяц дзень тыдня) і апісвае простай мовай, калі ён выконваецца.
  • Шыфратар/дэшыфратар Phillips Зашыфруйце або расшыфруйце тэкст шыфрам Phillips, які выкарыстоўвае восем ключавых квадратаў Полібія 5×5, што чаргуюцца праз кожны блок з пяці літар.